Supported browsers

Cyclr’s workflow builder is very powerful and as such we do suggest that you run the latest versions of our supported browsers:

  • Chrome
  • Firefox
  • Safari
  • Edge

Browser feature requirements

In addition, your browser should allow JavaScript and cookies in order to use Cyclr.

Supported operating systems

Cyclr is tested against all recent versions of Windows, Mac OSX, and Linux.

How to Install Connectors

Edit me